We fixed the following 4 bugs related to upgrade procedure to ELK 8.
Firstly, we fixed an issue with a script used to set the correct number of replicas for single-node installations, which was throwing an error in case a certain system index, already having the correct setting, was being affected by the procedure.
Moreover, we fixed issues related to waiting for the Elasticsearch cluster status to be back to green, which would have failed in case the first node was being upgraded and a new primary shard was being allocated on it, with the related replica not being able to be allocated on any node having a lower Elasticsearch version.
Furthermore, we ensured that Elasticsearch is not being restarted unnecessarily during updates.
Lastly, we fixed an issue in the script used to generate the additional Beats templates for El Proxy, which was failing for Winlogbeat, after ELK 8, due to the configuration of a mapping for an undeclared analyzer.
Updated packages
For NetEye 4.31 we updated the following packages:
Hi! I'm Davide and I'm a Software Developer with the R&D Team in the "IT System & Service Management Solutions" group here at Würth IT Italy. IT has been a passion for me ever since I was a child, and so the direction of my studies was...never in any doubt! Lately, my interests have focused in particular on data science techniques and the training of machine learning models.
Author
Davide Sbetti
Hi! I'm Davide and I'm a Software Developer with the R&D Team in the "IT System & Service Management Solutions" group here at Würth IT Italy. IT has been a passion for me ever since I was a child, and so the direction of my studies was...never in any doubt! Lately, my interests have focused in particular on data science techniques and the training of machine learning models.
NATS: Fix multi-tenancy configuration corruption in cluster environments When executing commands such as neteye install --restrict-services-to nats-server, neteye tenant config apply, or neteye satellite config create from a cluster node while nats-server was active on a different node, the shared Read More
Important: Grafana security update Type/Severity NetEye Product Security has rated this update as having a medium security impact. Topic An update for the grafana packages is now available for NetEye 4. Security Fix for NetEye 4.49 and 4.50 grafana-12.4.12_neteye3.31.4-1 Summary Four medium-severity CVEs Read More
Fixes for nginx and nginx-satellite We identified and fixed two issues affecting nginx resource management during service and resource restarts. nginx-satellite.service An issue could leave nginx worker processes running after nginx-satellite.service entered a failed state. These processes could continue listening Read More
When the GLPI inventory plugin is used to collect agent inventories, assets may fail to appear in GLPI even though the agents reach the server. The cause was a bug in the Icinga Web 2 SSO plugin: GLPI 11 marks Read More
Keycloak: Fix for Oversized Logout URL and Package Update This update addresses an issue where the logout redirect URL became excessively large, leading to failed logouts and HTTP 500 errors. When users belonged to a large number of groups, the Read More