Neteye install, update, upgrade procedures individual service logs weren’t saved in the correct format
We resolved a small issue where logs from parallel install or configurator playbooks were wrongly manipulated resulting in a different format from what they were supposed to be saved.
SIEM – Log Management
Elastic Stack missing systemd configuration files
We fixed a bug regarding missing systemd configuration files during the execution of some autosetups used for the correct configuration of Elastic Stack.
DPO verification containers were not restarted after a system reboot if running on Podman
We resolved a bug where the DPO blockchain verification containers with a restart policy Always were not successfully restarted after a host reboot if running on Podman.
Links inside Fleet Integrations redirected to a 404 page
We fixed an issue where clicking links inside some Fleet Integration dashboards redirected you to a nonexistent page instead of the actual resource.
APM – User Experience
Visual Monitoring with Alyvix
Transactions wrong status when thresholds were used
We fixed a bug in the Test Case reports view, where the transactions timeline could have shown the wrong status for single transactions in case a threshold (critical or warning) was applied.
Test Case enabling right after creation
Furthermore, we fixed an issue for which in the Test Case view it was not possible to enable a new Test Case in a session right after its creation without first refreshing the page. The operation is now possible, allowing a more seamless integration between these two actions.
We updated the following packages:
elastic-agent, elastic-agent-autosetup, elastic-agent-neteye-config, filebeat, filebeat-autosetup, filebeat-neteye-config, logstash, logstash-neteye-config, logstash-autosetup, logstash-neteye-config-autosetup, kibana, kibana-autosetup, kibana-neteye-config, elasticsearch, elasticsearch-autosetup, elasticsearch-neteye-config, elasticsearch-xpack-license to version 8.14.3_neteye3.65.3-1
elastic-blockchain-proxy to version 1.3.1-1
icingaweb2-module-alyvix, icingaweb2-module-alyvix-autosetup, icingaweb2-module-alyvix-configurator to version 0.55.4-1
icingaweb2-module-kibana to version 1.25.1-1
neteye-ansible-parallel to version 1.0.2-1
Emil Fazzi
Software Developer, R&D Team in the "IT System & Service Management Solutions" group at Würth IT Italy.
Author
Emil Fazzi
Software Developer, R&D Team in the "IT System & Service Management Solutions" group at Würth IT Italy.
NATS: Fix multi-tenancy configuration corruption in cluster environments When executing commands such as neteye install --restrict-services-to nats-server, neteye tenant config apply, or neteye satellite config create from a cluster node while nats-server was active on a different node, the shared Read More
Important: Grafana security update Type/Severity NetEye Product Security has rated this update as having a medium security impact. Topic An update for the grafana packages is now available for NetEye 4. Security Fix for NetEye 4.49 and 4.50 grafana-12.4.12_neteye3.31.4-1 Summary Four medium-severity CVEs Read More
Fixes for nginx and nginx-satellite We identified and fixed two issues affecting nginx resource management during service and resource restarts. nginx-satellite.service An issue could leave nginx worker processes running after nginx-satellite.service entered a failed state. These processes could continue listening Read More
When the GLPI inventory plugin is used to collect agent inventories, assets may fail to appear in GLPI even though the agents reach the server. The cause was a bug in the Icinga Web 2 SSO plugin: GLPI 11 marks Read More
Keycloak: Fix for Oversized Logout URL and Package Update This update addresses an issue where the logout redirect URL became excessively large, leading to failed logouts and HTTP 500 errors. When users belonged to a large number of groups, the Read More