Improved wait for cluster status during updates / upgrades
When restarting the Elasticsearch cluster during the NetEye update / upgrade procedure, is it possible let the restart procedure going even if the cluster has a “yellow” status. The check on the cluster status has been improved to allow at least the “yellow” status if the user specified it.
Resolving Elasticsearch Nodes Attempting to Join a New Cluster
During updates or upgrades, certain conditions may cause some Elasticsearch nodes to attempt to form a new cluster, resulting in nodes restart failures. This issue has been addressed by configuring the cluster.initial_master_nodes setting only during the initial bootstrap of the Elasticsearch cluster. Once the cluster is successfully established, this setting is permanently removed.
Addition of EnvironmentFile Directive in elastic-agent.service file
We have now made it possible to configure environment variables for the elastic-agent.service running on NetEye nodes. You can now configure environment variables by creating an environment file under /neteye/local/elastic-agent/conf/sysconfig/elastic-agent-user-customization.
List of updated packages
To solve the aforementioned issues, the following packages have been updated for NetEye 4.43:
Important: Grafana security update Type/Severity NetEye Product Security has rated this update as having a medium security impact. Topic An update for the grafana packages is now available for NetEye 4. Security Fix for NetEye 4.49 and 4.50 grafana-12.4.12_neteye3.31.4-1 Summary Four medium-severity CVEs Read More
Fixes for nginx and nginx-satellite We identified and fixed two issues affecting nginx resource management during service and resource restarts. nginx-satellite.service An issue could leave nginx worker processes running after nginx-satellite.service entered a failed state. These processes could continue listening Read More
When the GLPI inventory plugin is used to collect agent inventories, assets may fail to appear in GLPI even though the agents reach the server. The cause was a bug in the Icinga Web 2 SSO plugin: GLPI 11 marks Read More
Keycloak: Fix for Oversized Logout URL and Package Update This update addresses an issue where the logout redirect URL became excessively large, leading to failed logouts and HTTP 500 errors. When users belonged to a large number of groups, the Read More
Important: GLPI security update Type/Severity NetEye Product Security has rated this update as having a high security impact. Topic An update for the glpi packages is now available for NetEye 4. Security Fix for NetEye 4.49 glpi-11.0.9_neteye1.20.3-2 glpi-autosetup-11.0.9_neteye1.20.3-2 glpi-configurator-11.0.9_neteye1.20.3-2 Summary This is the Read More