We have resolved an issue in the update and upgrade process for the Elastic Stack. Previously, if the Enrollment Token for our Elastic Agent was manually revoked, the procedure could encounter an error when attempting to regenerate it.
Alyvix
We fixed a bug affecting cloned Alyvix dashboards for performance graphs. Previously, after cloning a dashboard, running the neteye tenant config apply <tenant> command would break the dashboard due to a missing datasource. The fix ensures that cloned dashboards now retain their correct datasource configuration, preventing this issue from occurring.
We updated the following packages:
elastic-agent, elastic-agent-autosetup, elastic-agent-neteye-config, filebeat, filebeat-autosetup, filebeat-neteye-config, logstash, logstash-neteye-config, logstash-autosetup, logstash-neteye-config-autosetup, kibana, kibana-autosetup, kibana-neteye-config, elasticsearch, elasticsearch-autosetup, elasticsearch-neteye-config, elasticsearch-xpack-license to version 8.15.2_neteye3.66.5-1
icingaweb2-module-alyvix, icingaweb2-module-alyvix-autosetup, icingaweb2-module-alyvix-configurator to version 1.0.3-1
icingaweb2-module-analytics, icingaweb2-module-analytics-autosetup to version 1.58.2-1
Davide Sbetti
Hi! I'm Davide and I'm a Software Developer with the R&D Team in the "IT System & Service Management Solutions" group here at Würth IT Italy. IT has been a passion for me ever since I was a child, and so the direction of my studies was...never in any doubt! Lately, my interests have focused in particular on data science techniques and the training of machine learning models.
Author
Davide Sbetti
Hi! I'm Davide and I'm a Software Developer with the R&D Team in the "IT System & Service Management Solutions" group here at Würth IT Italy. IT has been a passion for me ever since I was a child, and so the direction of my studies was...never in any doubt! Lately, my interests have focused in particular on data science techniques and the training of machine learning models.
Fixes for nginx and nginx-satellite We identified and fixed two issues affecting nginx resource management during service and resource restarts. nginx-satellite.service An issue could leave nginx worker processes running after nginx-satellite.service entered a failed state. These processes could continue listening Read More
When the GLPI inventory plugin is used to collect agent inventories, assets may fail to appear in GLPI even though the agents reach the server. The cause was a bug in the Icinga Web 2 SSO plugin: GLPI 11 marks Read More
Keycloak: Fix for Oversized Logout URL and Package Update This update addresses an issue where the logout redirect URL became excessively large, leading to failed logouts and HTTP 500 errors. When users belonged to a large number of groups, the Read More
Important: GLPI security update Type/Severity NetEye Product Security has rated this update as having a high security impact. Topic An update for the glpi packages is now available for NetEye 4. Security Fix for NetEye 4.49 glpi-11.0.9_neteye1.20.3-2 glpi-autosetup-11.0.9_neteye1.20.3-2 glpi-configurator-11.0.9_neteye1.20.3-2 Summary This is the Read More
Important: Keycloak security update Type/Severity NetEye Product Security has rated this update as having a high security impact. Topic An update for the keycloak packages is now available for NetEye 4. Security Fix for NetEye 4.49: 26.7.4_neteye1.46.1-1 Summary This Keycloak update (version Read More