30. 09. 2026 Davide Zeni Bug Fixes, NetEye

Bug Fixes for NetEye 4.49

Fixes for nginx and nginx-satellite

We identified and fixed two issues affecting nginx resource management during service and resource restarts.

nginx-satellite.service

An issue could leave nginx worker processes running after nginx-satellite.service entered a failed state. These processes could continue listening on the configured ports and cause Address already in use errors during a restart.

The fix ensures that the service shuts down cleanly and can be restarted successfully.

nginx PCS resource

Orphaned nginx worker processes could also cause the nginx PCS resource to fail during a resource restart. The remaining processes prevented the related filesystem from being unmounted, resulting in an unable to unmount error.

The fix ensures that all nginx worker processes are properly terminated before the resource restart, allowing the filesystem to be unmounted cleanly.

List of updated packages

The following packages have been updated for NetEye 4.49:

  • nginx-neteye-config. nginx-neteye-config-configurator, nginx-neteye-config-ha, nginx-neteye-config-autosetup to version 1.24.2-1

Davide Zeni

Davide Zeni

Author

Davide Zeni

Leave a Reply

Your email address will not be published. Required fields are marked *

Archive