We fixed a bug in SLM reports for which they were not using the availability information stored in the monitored objects status. So, in case the IDO DB retention policy deleted all the events related to a monitored object, the report showed that it was not possible to generate the report, even though useful information was present in the monitored object status.
For NetEye 4.16 we updated the following packages:
icingaweb2-module-slm, icingaweb2-module-slm-autosetup to version 4.5.3-1
NATS: Fix multi-tenancy configuration corruption in cluster environments When executing commands such as neteye install --restrict-services-to nats-server, neteye tenant config apply, or neteye satellite config create from a cluster node while nats-server was active on a different node, the shared Read More
Important: Grafana security update Type/Severity NetEye Product Security has rated this update as having a medium security impact. Topic An update for the grafana packages is now available for NetEye 4. Security Fix for NetEye 4.49 and 4.50 grafana-12.4.12_neteye3.31.4-1 Summary Four medium-severity CVEs Read More
Fixes for nginx and nginx-satellite We identified and fixed two issues affecting nginx resource management during service and resource restarts. nginx-satellite.service An issue could leave nginx worker processes running after nginx-satellite.service entered a failed state. These processes could continue listening Read More
When the GLPI inventory plugin is used to collect agent inventories, assets may fail to appear in GLPI even though the agents reach the server. The cause was a bug in the Icinga Web 2 SSO plugin: GLPI 11 marks Read More
Keycloak: Fix for Oversized Logout URL and Package Update This update addresses an issue where the logout redirect URL became excessively large, leading to failed logouts and HTTP 500 errors. When users belonged to a large number of groups, the Read More