We fixed the following 4 bugs related to El Proxy.
The first bug was that there was large RAM consumption during the verification in case the verified blockchain contained a large number of corruptions. With the fix, the list of found corruptions, which caused the problem, is now exported in a .ndjson.gz file, for easier consultation and to reduce memory usage.
The second bug was that the default value of message_queue_size was leading to errors in the verification depending on the size of the blockchain to be verified. Now the verification will work regardless of the configured value of message_queue_size.
Another bug was that the El Proxy verification command was too verbose and was reporting unnecessary information that was visible also in the final verification report.
Finally we fixed a bug that caused the acknowledge command to fail when used with reason or description parameter.
Updated packages
For NetEye 4.31 we updated the following packages:
elastic-blockchain-proxy and elastic-blockchain-proxy-autosetup to version 0.30.4-1
For a correct application of the fix, please remember to update also the DPO machine by running the neteye dpo setup command after the update, as described in our NetEye User Guide.
Davide Sbetti
Hi! I'm Davide and I'm a Software Developer with the R&D Team in the "IT System & Service Management Solutions" group here at Würth IT Italy. IT has been a passion for me ever since I was a child, and so the direction of my studies was...never in any doubt! Lately, my interests have focused in particular on data science techniques and the training of machine learning models.
Author
Davide Sbetti
Hi! I'm Davide and I'm a Software Developer with the R&D Team in the "IT System & Service Management Solutions" group here at Würth IT Italy. IT has been a passion for me ever since I was a child, and so the direction of my studies was...never in any doubt! Lately, my interests have focused in particular on data science techniques and the training of machine learning models.
NATS: Fix multi-tenancy configuration corruption in cluster environments When executing commands such as neteye install --restrict-services-to nats-server, neteye tenant config apply, or neteye satellite config create from a cluster node while nats-server was active on a different node, the shared Read More
Important: Grafana security update Type/Severity NetEye Product Security has rated this update as having a medium security impact. Topic An update for the grafana packages is now available for NetEye 4. Security Fix for NetEye 4.49 and 4.50 grafana-12.4.12_neteye3.31.4-1 Summary Four medium-severity CVEs Read More
Fixes for nginx and nginx-satellite We identified and fixed two issues affecting nginx resource management during service and resource restarts. nginx-satellite.service An issue could leave nginx worker processes running after nginx-satellite.service entered a failed state. These processes could continue listening Read More
When the GLPI inventory plugin is used to collect agent inventories, assets may fail to appear in GLPI even though the agents reach the server. The cause was a bug in the Icinga Web 2 SSO plugin: GLPI 11 marks Read More
Keycloak: Fix for Oversized Logout URL and Package Update This update addresses an issue where the logout redirect URL became excessively large, leading to failed logouts and HTTP 500 errors. When users belonged to a large number of groups, the Read More