We fixed several bugs regarding the NetEye first installation on a cluster. It is now possible to successfully run the neteye_secure_install without worrying about possible problems and interruptions.
In addition, we fixed the permissions of some configuration files.
Updated packages
For NetEye 4.30 we updated the following packages:
httpd-neteye-config to version 1.13.1-1
elastic-stack to version 7.17.9_neteye3.48.1-1
neteye-setup to version 1.105.1-1
mariadb-neteye-config to version 1.5.1-1
icingaweb2-module-logmanager to version 0.44.1-1
icingaweb2-module-tornado to version 1.6.2-1
icingaweb2-module-tornadocarbon to version 1.29.1-2
icingaweb2-module-alyvix to version 0.42.3-2
elastic-blockchain-proxy to version 0.28.2-2
grafana to version 8.5.10_neteye3.18.2-1
icinga2 to version 2.11.9_neteye1.48.6-1
eventhandler to version 1.8.3-3
Emil Fazzi
Software Developer, R&D Team in the "IT System & Service Management Solutions" group at Würth IT Italy.
Author
Emil Fazzi
Software Developer, R&D Team in the "IT System & Service Management Solutions" group at Würth IT Italy.
NATS: Fix multi-tenancy configuration corruption in cluster environments When executing commands such as neteye install --restrict-services-to nats-server, neteye tenant config apply, or neteye satellite config create from a cluster node while nats-server was active on a different node, the shared Read More
Important: Grafana security update Type/Severity NetEye Product Security has rated this update as having a medium security impact. Topic An update for the grafana packages is now available for NetEye 4. Security Fix for NetEye 4.49 and 4.50 grafana-12.4.12_neteye3.31.4-1 Summary Four medium-severity CVEs Read More
Fixes for nginx and nginx-satellite We identified and fixed two issues affecting nginx resource management during service and resource restarts. nginx-satellite.service An issue could leave nginx worker processes running after nginx-satellite.service entered a failed state. These processes could continue listening Read More
When the GLPI inventory plugin is used to collect agent inventories, assets may fail to appear in GLPI even though the agents reach the server. The cause was a bug in the Icinga Web 2 SSO plugin: GLPI 11 marks Read More
Keycloak: Fix for Oversized Logout URL and Package Update This update addresses an issue where the logout redirect URL became excessively large, leading to failed logouts and HTTP 500 errors. When users belonged to a large number of groups, the Read More