We updated the Elastic Stack to the latest bugfix version 7.17.11. In particular this version fixes a problem in Kibana, which was not properly handling some particular DSL queries. For more information on the fixes provided with this version, please refer to the official Elastic Stack website.
In case you have any Elasticsearch plugin installed on your Elasticsearch nodes, please remember to uninstall them before updating and reinstall them only after the update is concluded. This is needed because Elasticsearch plugins are build for specific Elasticsearch versions. In case any Elasticsearch plugin remains installed during the update, the update will stop and ask to uninstall the plugins.
Updated packages
For NetEye 4.30 we updated the following packages:
NATS: Fix multi-tenancy configuration corruption in cluster environments When executing commands such as neteye install --restrict-services-to nats-server, neteye tenant config apply, or neteye satellite config create from a cluster node while nats-server was active on a different node, the shared Read More
Important: Grafana security update Type/Severity NetEye Product Security has rated this update as having a medium security impact. Topic An update for the grafana packages is now available for NetEye 4. Security Fix for NetEye 4.49 and 4.50 grafana-12.4.12_neteye3.31.4-1 Summary Four medium-severity CVEs Read More
Fixes for nginx and nginx-satellite We identified and fixed two issues affecting nginx resource management during service and resource restarts. nginx-satellite.service An issue could leave nginx worker processes running after nginx-satellite.service entered a failed state. These processes could continue listening Read More
When the GLPI inventory plugin is used to collect agent inventories, assets may fail to appear in GLPI even though the agents reach the server. The cause was a bug in the Icinga Web 2 SSO plugin: GLPI 11 marks Read More
Keycloak: Fix for Oversized Logout URL and Package Update This update addresses an issue where the logout redirect URL became excessively large, leading to failed logouts and HTTP 500 errors. When users belonged to a large number of groups, the Read More