We fixed a bug in El Proxy related to the retry strategy for sending signed logs to Elasticsearch. Previously, after a document has been rejected from the Elasticsearch ingest pipeline, all non-signed logs were deleted during the retry phase including the mandatory “timestamp” field. Our solution now ensures that all mandatory fields remain intact during the retry strategy. Additionally, we enhanced the logging of El Proxy errors in the DLQ logs for easier debugging.
Upgrade Manager
We fixed a bug in the upgrade procedure related to fencing. The procedure now, whenever an update of pacemaker or corosync is present, ensures fencing is disabled to prevent possible issues when nodes are put in standby.
Furthermore, we fixed an issue related with the check of missing updates, which may have given an error in case a change of RedHat Release.
Updated packages
We updated the following packages:
elastic-blockchain-proxy, elastic-blockchain-proxy-autosetup, elastic-blockchain-proxy-configurator to version 1.2.5-1
neteye-upgrade-manger to version 0.54.5-1
Emil Fazzi
Software Developer, R&D Team in the "IT System & Service Management Solutions" group at Würth IT Italy.
Author
Emil Fazzi
Software Developer, R&D Team in the "IT System & Service Management Solutions" group at Würth IT Italy.
NATS: Fix multi-tenancy configuration corruption in cluster environments When executing commands such as neteye install --restrict-services-to nats-server, neteye tenant config apply, or neteye satellite config create from a cluster node while nats-server was active on a different node, the shared Read More
Important: Grafana security update Type/Severity NetEye Product Security has rated this update as having a medium security impact. Topic An update for the grafana packages is now available for NetEye 4. Security Fix for NetEye 4.49 and 4.50 grafana-12.4.12_neteye3.31.4-1 Summary Four medium-severity CVEs Read More
Fixes for nginx and nginx-satellite We identified and fixed two issues affecting nginx resource management during service and resource restarts. nginx-satellite.service An issue could leave nginx worker processes running after nginx-satellite.service entered a failed state. These processes could continue listening Read More
When the GLPI inventory plugin is used to collect agent inventories, assets may fail to appear in GLPI even though the agents reach the server. The cause was a bug in the Icinga Web 2 SSO plugin: GLPI 11 marks Read More
Keycloak: Fix for Oversized Logout URL and Package Update This update addresses an issue where the logout redirect URL became excessively large, leading to failed logouts and HTTP 500 errors. When users belonged to a large number of groups, the Read More